您好!欢迎进入广州某某楼宇智能科技有限公司官网 !

栏目导航
新闻资讯
新闻资讯
问题解答
联系我们
服务热线
020-66889888
邮箱:admin@163.com
地址: 广州市博文路唐南大厦A座58室
当前位置:主页 > 新闻中心 > 新闻资讯 >
但现在 Nginx -V 配置里面还没有
浏览: 发布日期:2018-03-11
    1
XiaoFaye   167 天前
nginx 用 http2 可以呀,你的问题具体是?最后几行都有--add-module=/build/nginx-ryOGNl/nginx-1.6.2/debian/,我担心这个路径我直接在 1.11.5 里面./configure 会编译出错。
 
想请教一下大神们, Nginx 正确升级的姿势应该是如何?谢谢
 
 Nginx 1.6.2 var debian9 回复  |  直到 2016-11-14 10:33:06 +08:00
    1
knightdf   2016-11-13 15:52:10 +08:00   ♥ 1
重新编译,备份原来的 nginx 可执行文件,替换后运行没问题就行,有问题就换回来....
    2
ivmm   2016-11-13 15:53:03 +08:00   ♥ 1
apt-get -t jessie-backports install nginx 
or 
apt-get -t jessie-backports upgrade nginx 
 
试试把, debian 8 的 bpo 是 1.9.10 
 
但讲道理, Nginx 还是编译的好, https://imququ.com/post/my-nginx-conf.html
    3
hsyu53   2016-11-13 16:01:42 +08:00 via iPad   ♥ 1
按文档说的操作,很轻松 
http://nginx.org/en/linux_packages.html#mainline
    4
Remember   2016-11-13 16:06:54 +08:00   ♥ 1
@ivmm backport +1
    5
ethanlu   2016-11-13 16:28:31 +08:00
@ivmm 谢谢! apt-get -t jessie-backports install nginx 可以了 
 
但现在 Nginx -V 配置里面还没有 --with-http_v2_module ,需要 ./configure 然后 make 吗?
    6
sobigfish   2016-11-13 17:33:54 +08:00
./configure 
--with-pcre=../pcrelib 
--with-pcre-jit 
--with-zlib=../zlibdir 
--with-http_ssl_module 
--with-stream 
--with-stream_ssl_module 
--with-http_v2_module 
--with-ipv6 
 
省略了部分 path 设置
    7
ivmm   2016-11-13 17:52:39 +08:00
@ethanlu 既然没有的话,那就只能编译,卸载二进制包的 nginx 吧
    8
LazyZhu   2016-11-14 01:34:03 +08:00
难道你们不知道 debain 除了 nginx 还有 nginx-full 吗? 
https://packages.debian.org/jessie-backports/nginx-full
    9
msg7086   2016-11-14 10:33:06 +08:00
这种软件包冲突,最快的办法是卸掉软件包然后重新装上新的。反正又不会丢配置,怕什么。 
想玩高版本的话可以直接下载 experimental 版, 1.11.5 ,反正也没什么不稳定的。